Encoo has observed that all affected LTE backup services have successfully restored following improvements observed on the Telstra mobile network.
This incident is now considered resolved from Encoo’s perspective. We will continue to monitor the previously impacted services and provide further updates if the situation changes.
Encoo NOC
Posted Jul 09, 2026 - 08:02 AEST
Monitoring
Dear Customers
Encoo has observed Telstra LTE backup services gradually restoring across multiple customer sites over the past hour, indicating the Telstra mobile network issue is improving.
We will continue to monitor service recovery as connectivity is restored. At this stage, we expect affected services to continue recovering as Telstra progresses with their restoration activities.
Further updates will be provided as more information becomes available.
Encoo NOC
Posted Jul 08, 2026 - 09:33 AEST
Investigating
Dear Customers
Encoo has identified an issue affecting a number of customer LTE backup connections that utilise the Telstra mobile network.
The issue appears to have started at approximately 5:52 AM AEST and is impacting some Telstra 4G and 5G mobile services. Based on early indicators, this may be related to a wider Telstra mobile network issue.
Affected Encoo customer sites using Telstra LTE as a backup connection may currently show their LTE backup service as offline. Primary connectivity services are not impacted.
At this stage, only limited information is available regarding the Telstra mobile network issue. Encoo will continue to monitor the situation and provide updates as more details become available. Services are expected to automatically restore once the underlying Telstra mobile network issue is resolved.
Customers can also monitor Telstra’s public communication channels for updates: https://x.com/Telstra
Further updates will be provided as more information becomes available.