Major Third-Party Outage (Power)
Incident Report for Encoo Status
Resolved
This incident has been resolved.
Posted May 26, 2021 - 08:08 AEST
Investigating
A widespread outage from the Gold Coast to Caboolture is affecting 375k Energex customers. Some customers site may be down due to the on-going issues. Please refer to Energex website/twitter for more details.
https://www.energex.com.au/
https://twitter.com/Energex/status/1397048653605261312?ref_src=twsrc%5Egoogle%7Ctwcamp%5Eserp%7Ctwgr%5Etweet
Posted May 25, 2021 - 15:03 AEST